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Advanced TINY MCE

Add more functions to TinyMCE in PrestaShop (icons, font size, font family,
special character, find and replace, preview, etc.). Give you more control over

tools included in the PrestaShop text editor.

A product of PrestaHero
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I INTRODUCTION

Advanced Tiny MCE allows you to add more functions to the text editor in PrestaShop
(icons, font size, font family, special character, find and replace, preview, etc.). Give you more

control over tools included in the PrestaShop text editor.

*"Advanced Tiny MCE" is compatible with PrestaShop 1.6.x, 1.7.x and PrestaShop 8.x

. INSTALLATION

¢ Navigate to “Modules / Modules Manager” > click on “Upload a module / Select
file".

e Select the module file “etstinymce.zip” from your computer then click on “Open”
to install.

¢ Click on “Configure” button of the module you just installed to open the module’s

configuration page.

ll. CONFIGURATION

From your installed module list (located at “Modules/Module Manager”), find

“Advanced Tiny MCE"” and then click on the “Configure” button to open its configuration
page.

On the "Tiny MCE" page, you can select the types of text formatting option to display on

TinyMCE menu bar. Our module supports the following formatting tools:

e Source code
e Fontsize

e Font



Emoticons
Anchor

Bold

Italic

Underline
Strikethrough
Block quote

Link

Undo

Redo

Align

Bullet list
Numbered list
Table

Image

Video

Paragraph
Special character
Print

Preview

Find and replace
Horizontal line
Text color
Background color
Decrease indent
Increase indent
Clear formatting
Fullscreen

Insert/edit code sample



You can activate/disable the formatting tools you want. Drag and drop the arrow icon to

sort the order of formatting tools.

Modules / etstinymce / # Configure

Configure Back Translate Check update Manage hooks
Advanced Tiny MCE L J L J

<> Tiny MCE £ Settings
Tiny MCE

options Icon Display

O selectall/Unselectall

Source code o + @D
Font size Fontsize - 4+ (Ooff
Font Font - 4+ (Ooff
Emoticons © 4 (off
Anchor H %+ (Ooff
Bold B + @D
Italic I + @D
Underline z + @D
strikethrough 5 + @D
Block quote 6 + @D
Link & + @D
Undo 4 4+ Coff
Redo g + fi
Align E + @D
Bullet list = + @D
Numbered list = + @D
Table = + @D
Image ® + @D
video & + @
Paragraph Paragraph ~ + @
Special character Q 4+ (Coff
Print ] off
Preview = off
Find and replace [1] off

Horizontal line -

Text color A off
Background color [ |
Decrease indent = off

L S S I I

Increase indent = off
Clear formatting I off
Fullscreen b3 off
Inservedit code sample G off

On the "Settings" page, you can configure how the TinyMCE formatting tools will be

displayed on text editor area:



i Manage hooks

i Translate i Check update

Configure

AdvancetPTiny MCE

</> Tiny MCE & Settings

Settings

EnabletinyMCE @) ves
Display menu bar on text editor No

Display mode Light mode v

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

Ignore TinyMCE in Modules

SELECT MODULES

45 Configuration

[ Activate module for this shop context: all shops.

This is the default text editor of PrestaShop:

(O paragraph ~

With an intensity that rivals the night sky, Tiffany Victoria celebrates the blazing brilliance of Tiffany diamonds. The organic vina motif of this ring complemants tha beauty of
mixed-cut diamond:

« “Display menu bar on text editor” option is enabled:



File > Edit> Insert> View~ Format~ Table > Tools ~

Fontsizes ¥ Font Family +

B paagaph e ()

With en intensity that rivals the night sky, Tiffany Victoris celebrates the blszing brilliance of Tiffany diamonds. The organic vine motif of this ring complements the beauty of

mixed-cut diamonds.

If you want to hide the Tiny MCE formatting tools for specific admin controller, click on

“Select admin controller” button to show the list of admin controller:

Modules / etstinymee / % Configure

Configure
Advanced Tiny MCE

</> Tiny MCE % Settings

Settings

Enable tinyMCE

@ ves

Display menu bar on text editor No

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

Search

[ AdminPatterns

() AdminAdminPreferences - Administration

[ AdminCarriers - Carriers
[ AdminCategories - Categories
[ AdminContacts - Contacts

[ AdminParentCustomerThreads - Customer Service

Ignore TinyMCE in Modules

SELECT MODULES

Display mode Light mode

O Adminstock

() AdminAdvancedParameters - Advanced
Parameters

() AdminCartRules - Cart Rules
(O AdminstockConfiguration - Configuration
() AdminCountries - Countries

[ AdminCustomerThreads - Customer Service

[ AdminstockManagement

[ AdminModulesNotifications - Alerts

[) AdminParentAttributesGroups - Artrioutes &
Features

[ AdminCatalog - Catalog

[) CONFIGURE - Configure

[ AdminSlip - Credit Slips

[ AdminParentCustomerPreferences - Customer
Settings

=

Translate

Check update Manage hooks

01 AdminAddresses - Addresses
[ AdminAtributesGroups - Attributes

[ AdminManufacturers - Brands

[ AdminParentManufacturers - Brands & Suppliers
[ AdminSpecificPriceRule - Catalog Price Rules

[ AdminParentStores - Contact

[ AdminCurrencies - Currencies

[ AdminCustomerPreferences - Customer Settings

(] AdminParentCustomer - Customers v

e Use the search box to search for the controller you want to ignore.



e You can select multiple controllers. The selected items will display under the list

box.

Configure
Advanced Tiny MCE

<> Tiny MCE # Settings

Settings

Enable tinyMCE

[ R

Display menu bar on text editor No

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

h

[ AdminPatterns

() AdminAdminPreferences - Administration

) AdminCarriers - Carriers

[J AdminCategories - Categories

[ AdminContacts - Contacts

[ AdminParentCustomerThreads - Customer Service

X AdminCartRules - Cart Rules

Clear all

Ignore TinyMCE in Modules

SELECT MODULES

Display mode

X CONFIGURE - Configure

[ Adminstock

£ AdminAdvancedparameters - Advanced
Parameters

AdminCartRules - Cart Rules
[ AdminstockConfiguration - Configuration
[ AdminCountries - Countries

[ AdminCustomerThreads - Customer Service

X AdminCurrencies - Currencies

Click on “Save” button to finish.

Light mode v

[ Back J Translate

[ AdminStockManagement

[ AdminModulesNotifications - Alerts

[ AdminParentAtributesGroups - Attributes &
Features

[ AdminCatalog - Catalog
CONFIGURE - Configure

[ Adminslip - Credit slips

[ AdminParentCustomerPreferences - Customer
Settings

Check update Manage hooks

[ AdminAddresses - Addresses
() AdminAttributesGroups - Attriputes

[ AdminManufacturers - Brands

[) AdminParentManufacturers - Brands & Suppliers
[ AdminSpecificPriceRule - Catalog Price Rules

[J AdminParentStores - Contact
AdminCurrencies - Currencies

[ AdminCustomerPreferences - Customer Settings

[ AdminParentCustomer - Customers v

If you want to hide the Tiny MCE formatting tools for specific modules, click on “Select

module” button to show the list of installed modules:



Modules / etstinymee / £ Configure

Configure [ Back J Translate Check update Manage hooks
Advanced Tiny MCE - - u S
</> Tiny MCE £ Settings
Settings
enabletinyMcE @) ves
Display menu bar on text editor No
Display mode Light mode v
Ignore Tiny MCE in Admin Controller
Ignore TinyMCE in Modules
Search
[0 Wishlist (blockwishlist) [ Contact form (contactform) [ Dashboard Goals (dashgaals) [ Google sitemap (gsitemap)
[ Product Comments (productcomments) () Banner (ps_banner) [ Category tree links (ps_categorytree) () Payments by check (ps_checkpayment)
[ Contactinformation (ps_contactinfo) [ Cross-selling (ps_crossselling) [0 Custom text block (ps_customtext) [ Customer data privacy block (ps_dataprivacy)
() Newsletter subscription (ps_emailsubscription) [ Order Notifications on the Favicon [) Featured products (ps_featuredproducts) [ Image slider (ps_imageslider)
(ps_faviconnotificationboy
[ Link List (ps_linklist) ) Main menu (ps_mainmenu)
[ Social media share buttons (ps_sharebuttons) [ Shopping cart (ps_shoppingcart) [ Social media follow links (ps_socialfollow) [ Theme Customization (ps_themecusto)
[ Bank transfer (ps_wirepayment) [ Data mining for statistics (statsdata) [ Stats Dashboard (statsforecast) [ Welcome (welcome)
[ Official GDPR compliance (psgdpr) [ Prestashop Marketplace in your Back Office [ Prestashop Checkout (ps_checkout) [ PrestaShop Metrics (ps_metrics)
5_mbo)
(ps.mbo) [ PS Social with Facebook &amp; Instagram [] Marketing with Google (psxmarketingwithgoogle)

e Use the search box to search for the module you want to ignore.

e You can select multiple modules. The selected items will display under the list box.



Configure [ Back J Translate Check update Manage hooks
AdvancefPTiny MCE ( ( J J L

</> Tiny MCE £ Settings

Settings
EnabletinyMCE @) Yes
Display menu bar on text editor No
Display mode Light mode e

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

Ignore TinyMCE in Modules

SELECT MODULES

Search
[ Wishlist (blockwishlist) [ Contact form (contactform) [ Dashboard Goals (dashgoals) [ Google sitemap (gsitemap)
[ Product Comments (productcomments) [ Banner (ps_banner) Category tree links (ps_categorytree) () Payments by check (ps_checkpayment)
[ Contact information (ps_contactinfo) [ Cross-selling (ps_crossselling) [0 Custom text block (ps_customtext) [ Customer data privacy block (ps_dataprivacy)
[) Newsletter subscription (ps_emailsubscription) [ Order Notifications on the Favicon () Featured products (ps_featuredproducts) () Image slider (ps_imageslider)
(ps faviconnatficationbo) [ Link List {ps_linklist) [J Main menu (ps_mainmenu)
[ Social media share buttons (ps_sharebuttons) Shopping cart (ps_shoppingcart) [ Social media follow links (ps_socialfollow) [) Theme Customization (ps_themecusto)
[ Bank transfer (ps_wirepayment) [ Data mining for statistics (statsdata) [ Stats Dashboard (statsforecast) O Welcome (welcome)
[ Official GDPR compliance (psgdpr) [ Prestashop Marketplace in your Back Office [ PrestaShop Checkout (ps_checkout) [ PrestaShop Metrics (ps_metrics)
(ps_mbo) [ PS Social with Facebook &amp; Instagram [ Marketing with Google (psxmarketingwithgoogle) v
X Category tree links (ps_categorytree) X Shopping cart (ps_shoppingcart)
Clear all

Click on “Save” button to finish.

IV. TINY MCE FORMATTING TOOLS

e Source code: this code editor makes it easier to modify the HTML, and it's a very

useful add-on for power users.
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Source cade

the blazing brillance of Tiftany
of mivachaun diamends.<ip>

fes froem your nstagram. Tag your products. Now anyene £an parchase them.
Jpeas in Prestashop back office, ST ik you'd Expect </

¢ Font size: the TinyMCE rich text editor comes with 7 font size options by default,
ranging from 8pt to 36pt. Depending on how TinyMCE is configured, users can

select a font from the menu bar or toolbar.

P . : . R o om =
Love Ring in Rose Gold with Diamonds 3 Standard product ¢ | [3] e s Transiate Saies Product s R

Basicsewings  Quantities  Shipping  Pricng  SEO  Options

Combinations [

- \ 4" @ simple product
i@;@ ] r ’- © Product with combinations

Reference

Summary | Description "

Fle~ Edt™ |nsertT View ™ Formatv Table v Taols ¥

Quantity [7]
A < FouSzesw FomRamiy~ ) [] B I U T m o= @ =vi=v =~ @~ M O raagoph~ ()
L= A ™

328

N Advanced settings in [/} Quantities

10pt
o
14pt Price
180t
. Tax excluded Tax included
. § | 370.000000 % 370
Tax rule
US-AL Rate (4%) -
Advanced settings In (] Pricing

Duplicate Go to catalog. Add new product

e Font family: TinyMCE comes with 17 font options by default. Depending on the
editor configuration, users can select a font from the menu bar or the toolbar (via

the font select dropdown).
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%% PrestaShop

Love Ring in Rose Gold with Diamonds ] Standard product & en & » @ = @

Basic settings Juantitie pping  Pri

Ay Combinations []
@ simple product

covar
Reference 7
Summary
Fie v Edit = View = Format > Table v Toaks = :
Quantity [I]
F Font Family = .= - @\~ Paragraph =
- 28
Andile Moae
- A Helvanced settigs i
MPROVE Arial Black
Book Antiqua .
Price [
Comic Sans MS
Tax excluded Tax included
370000000 ERE
Helvetica Toxruie
[a— USAL Rate (4%)
Eumpe Aehvanced sestings

CONFIGURE Tahama

¢ Emoticons: lets users insert emoji into TinyMCE's editable area.

% PrestaShop - Q @venmyshop A L @

Love Ring in Rose Gold with Diamonds u Standard product ¢ en e AL )

Basic settings

Reference [;
Summary u
abie ~
Quantity [
e =iz @~ e
328

With an intensity that rivals tha ight sky,
IMPROVE maxed-cut chamonds

US-AL Rate (49%)

e Anchor: lets users specify a custom name for the anchor in the URL type ahead

drop down.
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Text format tools: bold, italic, underline, strike through.

[ ]
Love Ring in Rose Gold with Diamonds o Standard product ¢ | [3] en ¢ ,,.h.:s., SE,
Basic settings Quantities Shipping Options
Combinations [7]
iy @ simple product
@ é?m@ P O Product with combinations
Reference [1]
Summary Description a5
File ¥ Editv Insert> View~ Format ¥ Table v Tools ¥
Quantity [
A <> Fomszesv fonthamiyr © [] B 1 U " o & SEv=vi=~ - MW @ ragaph~ ()
& s i — 328
A Advanced settingsin [} Quantities
Bold text
Italic text
‘Underfine text Price D
Strike through-text
Wi an sty sha civals tha igh sk, Tifany Victoia celbratesthe bazing brlance of Tiany diamonds. The organic vine Mo of this fing complaments the beausy of Tax excluded Taxinduded
e el S 370000000 s 370
Tax rule
US-AL Rate (4%) .
Advanced settings in [} Pricing
¢ Block quote and link: format a paragraph into a block quote. Insert a link into the

paragraph.
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. . . " PS B =
Love Ring in Rose Gold with Diamonds a Standard product ¢ | [ Lk e s" Productiet Ow

Basic settings Quantities. Shipping Pricing SEO Options.

Combinations [
@ - @ Simple product
ﬁﬁ \

O Product with combinations.
T

Reference [1]
Summary  Description “
File * Edit ¥ Insert > View > Format > Table ¥ Tools ¥
| Quantity [7]
A o Foszesv Fontfamiy s @ [ B I U T m o= & =~ =~ >~ W O Pasgaph~ ()
228
s o -
Al Advanced settingsin [ Quantities
Bold text
Tralic text
Underfine text Price []
Strike-through-text
Tax excluded Tax included
s | 370.000000 5370
Taxrule
US-AL Rate (4%) -

Advanced settings in [ Pricing

Insert link

unt heps:/fwwwe tiffany.com/
Texttodisplay  Tiffany Victoria

Rel

Target

¢ Undo/redo tool.

¢ Align tools: align left, align right, align center, justify.
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Quick Access » Qs

it el circthone @ Viewmyshop Q1 ® (2]

fii

Love Ring in Rose Gold with Diamonds L) Standard product ¢ | [3] en ¢ » o

Basic settings Quantities Shipping Pricing SEO  Options

” Combinations [2]

' / @ simple product
¢ [ O Product with combinations

Reference [7]

Advanced settings in [} Pricing

Summary Description o
File v Edit> Insert> View~ Format~ Table > Tools *
Quantity 7
FontSizes v FontFamity v (O) B 7 U XT w o & Evi=vi=- - MW O reagaphy ()
= 328
= =l — Aign Left
A Advanced settings in [} Quantitie:
With an intensity that rivals the night sky, Tiffany Victoria celebrates the blazing brilliance of Tiffany dian  — A" Right "of this ring complements the beauty of
mixed-cut diamonds.
Align Center
‘ = Justity Price [
i Tax excluded Tax included
| 5 | 370000000 § 370
|
| Tax rule
} US-AL Rate (4%) o

¥ m Online ‘¢ m ‘ Duplicate Go to catalog Add new product

e Bullet list: default, circle, disc, square list.
e Numbered list: default, lower Alpha, lower Greek, lower Roman, upper Alpha,
upper Roman.

e Table manager tool:

Quick Access v Q searchte.g.: p

@ Viewmyshop 1 ‘§° e

Love Ring in Rose Gold with Diamonds 3 Sandardproduct ¢ | [ e s, B &

Basicsettings  Quantities Shipping Pricing SEO Options

” Combinations [

@ simple product

O Product with combinations

Reference [7]

Summary Descr u
file > Edit~ Insert~ View > Format~ Table * Tools *
Quantity [
Fontsizes ¥  FontFamlly v () I B 'Y T wn LY =-i=vi=~ @~ A B raagraph~ ()
H 328
A Advanced settingsin [} Quantities
With an intensity that rivals the night sky, Tiffany Victoria celebrates the blazing brilliance of Tiffany diamonds. The organic vine mo 2. he beauty of
mixed-cut diamonds.
Price I
cell »
- Tax excluded Tax included
A Row »
. $  370.000000 $ 370
A Column »
- Tax rule
Y
US-AL Rate (4%) -

Advanced settings in [ Pricing

[ ontine (i m Duplicate Go to catalog Add new product

¢ Insert/edit photo/video :
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Insert/edit image

- ]

Image description

Dimensions  Constrain proportions.

I oo

Insert/edit video
General | Embed

Source

Alternative source.

Poster

Dimensions. 1 Constrain proportions

[

e Paragraph format tool:
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Love Ring in Rose Gold with Diamonds

Basic settings Quantities. Shipping Pricing SEO Options

o @ W

|

Summary | Description
File v Editv Insert ¥ View > Format ¥ Table ¥ Tools ¥

A <> Fomszesv Fomtfamiyr © [ B Z U T w o 6
& = M —

Standard product ¢ | [3] en

With an intansity that rivals the night sky, Tiffany Victoria "9 Tiffany diamonds.
‘mixed-cut diamonds.

" @ =

Translate Sales Productlist Help

o

Combinations [7]

@ Simple product

O Product with combinations

Reference [

o
Quantity [7]
328

Paragraph
= Advanced settings In [} Quantities
ore

Header 1  price 3]

Header 2 Tax excluded Tax included
Header:3 $ | 370.000000 s 370
Header 4
Tax rule
Wesder s
US-AL Rate (4%) v
a8

I Advanced settings In [} Pricing

. o @)

[ Duplicate I [ Go to catalog | [ Add new product

Insert special character:

Special character

3

Print

Preview
Find and replace

Add horizontal line
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Find and replace

0 Mateh case
0 whole words

And Replace Replace a

e Text color

Sales Product st Help

@

o |

o

‘ Clothes ‘ Standard product

Basic settings Combinations ~ Shipping ~ Pricing  SEO  Options

O TF

Combinations ®
O Simple product

® Product with combinations

advanced sextngs i [} Combinations

Reference ®

Summary

demo_1

o B I YSNPE E-iE @ BB amgwn AN 2vEEL S0

clothes someone wears tell us about their cultural identity and life statyl ] to describe someone to Price ®

someone else, Tax excluded Taxincluded
| s | 100.000000 ‘ ‘ s | 100 |

| Toxre

| USFLRate (6%) v
‘Advanced settngs In [} Pricing
Categories ®
| Search categories 0\‘

137 of
ASSOCIATED CATEGORIES

[comen | [[rsamonoe |

e Background color
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Clothes Standard product @ |es= ;EI‘; . ‘Eﬂ -
Basic settings Combinations Shipping Pricing SEQ Options
Combinations ®
= = © Simple product
g T]F @ Product with combinations
Advanced settings In (] Combinations
Reference ®
Summary
demo_1
o B I U S9N Q= = v =@y B B raragaph v A~ # v = = L 6
%
The clothes someone wears tell us about their cultural identity and life status. When ibe someone to Price ®
someone else, q Taxexcluded Taxincluded
$ 100.000000 $ 100
I
US-FL Rate (6%) e

Advanced settings In (] Pricing

Categories @

] m oniine (@l E

Go to catalog

[ Add new product

Decrease indent

e Increase indent

e Clear formatting: You can easily clear all formatting (such as bold, underline, italics,
color, superscript, subscript, and more) from your text and return your text to its
default formatting styles.

e Fullscreen

e Insert/edit code sample
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Insert/Edit Code Sample

Language
HTML/XML

)
HTMLAML

JavaScript
css

PHP
Ruby

Python

V. THANKYOU

Thank you again for purchasing our product and going through this documentation. We
hope this document is helpful and efficient in the installation and usage of Advanced

Tiny MCE module. If you do have any questions for which the answer is not available in

this document, please feel free to contact us.
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