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Advanced TINY MCE

Add more functions to TinyMCE in PrestaShop (icons, font size, font family,
special character, find and replace, preview, etc.). Give you more control over

tools included in the PrestaShop text editor.

A product of PrestaHero
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I INTRODUCTION

Advanced Tiny MCE allows you to add more functions to the text editor in PrestaShop
(icons, font size, font family, special character, find and replace, preview, etc.). Give you more

control over tools included in the PrestaShop text editor.

*"Advanced Tiny MCE" is compatible with PrestaShop 1.6.x, 1.7.x and PrestaShop 8.x

. INSTALLATION

¢ Navigate to “Modules / Modules Manager” > click on “Upload a module / Select
file".

e Select the module file “etstinymce.zip” from your computer then click on “Open”
to install.

¢ Click on “Configure” button of the module you just installed to open the module’s

configuration page.

ll. CONFIGURATION

From your installed module list (located at “Modules/Module Manager”), find

“Advanced Tiny MCE"” and then click on the “Configure” button to open its configuration
page.

On the "Tiny MCE" page, you can select the types of text formatting option to display on

TinyMCE menu bar. Our module supports the following formatting tools:

e Source code
e Fontsize

e Font



e Emoticons

e Anchor
e Bold
o ltalic

e Underline
e Strikethrough

e Block quote

e Link

e Undo

e Redo

o Align

e Bulletlist

e Numbered list

e Table

e Paragraph

e Special character
e Print

e Preview

e Find and replace
e Horizontal line

e Text color

e Background color
e Decrease indent
e Increase indent
e Clear formatting
e Fullscreen

e Insert/edit code sample

You can activate/disable the formatting tools you want. Drag and drop the arrow icon to

sort the order of formatting tools.



Modules / etstingmee §

Manage hooks

Configure pack | | Transiate
Advanced Tiny MCE -

> Tiny MCE 43 Settings

© o ensure that your “Advanced TinyMCE" module works correctly, please follow these simple steps to override the default TinyMCE in PrestaShop:
« First, navigate to the "fjs" directory in your Prestashop root folder and rename the folder "tiny_mce” to “tiny_mce1".
+ Next, locate the "/etstinymee/js/tinymee" folder and copy the entire "tinymce” folder. Paste this copied folder into the js” directory and rename the pasted folder from "tinymce” to "tiny_mce".
+ Then, locate the */etstinymce/views/css/skins” folder, copy and paste "skins" folder into the "/js/tiny_mcer” directory.
+ Finally, navigate to “Advanced parameters > Performance” page on your back office and clear website cache.

Optiens leon Display

[ Select all/Unselect all

Source code © + @

Font size Font size = +
Font Font = +
Ematicons © 4 o
Anchor [n] 3 (of
Bold B +
alic 7 +
Underline Ea +
Strikethrough 5 +
Block quote % +
Link +
undo 4
Reda [ +
Align H +
Bullet list +
Numbered list = &
Table ;1 +
Paragraph Paragraph = 4
Special character O +
print - + (oH
Preview - +
Find and replace H g
Horizontal line - & (JoR
Text color A +
Background color [ ] 4+ (7o
Decrease indent = +
Increase indent = +
Clear formatting I 4 off
Fullscreen i +
Insertiedit code sample o 4

On the "Settings" page, you can configure how the TinyMCE formatting tools will be

displayed on text editor area:



i Manage hooks

i Translate i Check update

Configure

AdvancetPTiny MCE

</> Tiny MCE & Settings

Settings

EnabletinyMCE @) ves
Display menu bar on text editor No

Display mode Light mode v

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

Ignore TinyMCE in Modules

SELECT MODULES

45 Configuration

[ Activate module for this shop context: all shops.

This is the default text editor of PrestaShop:

(O paragraph ~

With an intensity that rivals the night sky, Tiffany Victoria celebrates the blazing brilliance of Tiffany diamonds. The organic vina motif of this ring complemants tha beauty of
mixed-cut diamond:

« “Display menu bar on text editor” option is enabled:



File > Edit> Insert> View~ Format~ Table > Tools ~

Fontsizes ¥ Font Family +

> H —

~ | B

~ M B Paagraph > ()

With en intensity that rivals the night sky, Tiffany Victoris celebrates the blszing brilliance of Tiffany diamonds. The organic vine motif of this ring complements the beauty of

mixed-cut diamonds.

If you want to hide the Tiny MCE formatting tools for specific admin controllers, click on

“Select admin controller” button to show the list of admin controllers:

Modules / etstinymee / % Configure

Configure
Advanced Tiny MCE

</> Tiny MCE % Settings

Settings

Enable tinyMCE

@ ves

Display menu bar on text editor No

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

Search

[ AdminPatterns

() AdminAdminPreferences - Administration

[ AdminCarriers - Carriers
[ AdminCategories - Categories
[ AdminContacts - Contacts

[ AdminParentCustomerThreads - Customer Service

Ignore TinyMCE in Modules

SELECT MODULES

Display mode Light mode

O Adminstock

() AdminAdvancedParameters - Advanced
Parameters

() AdminCartRules - Cart Rules
(O AdminstockConfiguration - Configuration
() AdminCountries - Countries

[ AdminCustomerThreads - Customer Service

{ Back J Translate

[ AdminstockManagement

[ AdminModulesNotifications - Alerts

[) AdminParentAttributesGroups - Artrioutes &
Features

[ AdminCatalog - Catalog

[) CONFIGURE - Configure

[ AdminSlip - Credit Slips

[ AdminParentCustomerPreferences - Customer
Settings

Check update Manage hooks

01 AdminAddresses - Addresses
[ AdminAtributesGroups - Attributes

[ AdminManufacturers - Brands

[ AdminParentManufacturers - Brands & Suppliers
[ AdminSpecificPriceRule - Catalog Price Rules

[ AdminParentStores - Contact

[ AdminCurrencies - Currencies

[ AdminCustomerPreferences - Customer Settings

(] AdminParentCustomer - Customers v

e Use the search box to search for the controller you want to ignore.



e You can select multiple controllers. The selected items will display under the list

box.

Configure
Advanced Tiny MCE

<> Tiny MCE # Settings

Settings

Enable tinyMCE

[ R

Display menu bar on text editor No

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

h

[ AdminPatterns

() AdminAdminPreferences - Administration

) AdminCarriers - Carriers

[J AdminCategories - Categories

[ AdminContacts - Contacts

[ AdminParentCustomerThreads - Customer Service

X AdminCartRules - Cart Rules

Clear all

Ignore TinyMCE in Modules

SELECT MODULES

Display mode

X CONFIGURE - Configure

[ Adminstock

£ AdminAdvancedparameters - Advanced
Parameters

AdminCartRules - Cart Rules
[ AdminstockConfiguration - Configuration
[ AdminCountries - Countries

[ AdminCustomerThreads - Customer Service

X AdminCurrencies - Currencies

Click on “Save” button to finish.

Light mode v

[ Back J Translate

[ AdminStockManagement

[ AdminModulesNotifications - Alerts

[ AdminParentAtributesGroups - Attributes &
Features

[ AdminCatalog - Catalog
CONFIGURE - Configure

[ Adminslip - Credit slips

[ AdminParentCustomerPreferences - Customer
Settings

Check update Manage hooks

[ AdminAddresses - Addresses
() AdminAttributesGroups - Attriputes

[ AdminManufacturers - Brands

[) AdminParentManufacturers - Brands & Suppliers
[ AdminSpecificPriceRule - Catalog Price Rules

[J AdminParentStores - Contact
AdminCurrencies - Currencies

[ AdminCustomerPreferences - Customer Settings

[ AdminParentCustomer - Customers v

If you want to hide the Tiny MCE formatting tools for specific modules, click on “Select

module” button to show the list of installed modules:



ce / #Configure

Configure

Advance

< Tiny MCE

<>

iny MCE

& Settings

Settings

@ ves

Enable tnyMCE

Display menu bar on text editor No

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

Ignore TinyMCE in Madules

SELECT MODULES

Search

O Wishiist (blockwishlisty
[0 Product Comments (productcomments)
(0 Contact Information (ps_contactinfo)

[ Newsletter subscription (ps_emailsubscription)

[0 Social media share buttons (ps_sharebuttons)
O Bank wransfer (ps_wirepayment)

O Official GDPR compliance (psgdpr)

Display mode Light mode

() Contact form (contactformy

[ Banner (ps_banner)

O Cross-selling (ps_crossselling)

[ Order Notifications an the Favicon
(ps_faviconnotificationbo)

[ Shopping cart {ps_shoppingcart)

[ Data mining for statistics (statsdata)

[) Prestashop Marketplace in your Back Office
(ps_mbo)

Back | Translate | [ Check update

() Dashboard Goals (dashgoals)
[ Category tree links (ps_categorytree)

0 Custom text block (ps_customrext)

() Featured products (ps_featuredproducts)
[0 ik List (ps_linklist)

[0 Sedal media follow links (ps_socialfollow)
[ Stats Dashboard (statsforecast)

[ Prestashop Checkout (ps_checkout)

[ PS Social with Facebook &amp; Instagram

) Google sitemap (gsitemap)
) Payments by check (ps_checkpayment)

) Customer data privacy block (ps_dataprivacy)
() Image slider (ps_imageslider)

O Main menu {ps_mainmenu)

[ Theme Customization (ps_themecusto)

O Welcome (welcome)

[ PrestaShop Metrics (ps_metrics)

) Marketing with Google (psxmarketingwithgoogle)

Use the search box to search for the module you want to ignore.

You can select multiple modules. The selected items will be displayed under the

list box.

Configure
Advance

iny MCE

Tiny MCE & Settings

Settings

@ ves

Enable tinyMCE

Display menu bar on text editor No

Ignore Tiny MCE in Admin Controller

SELECT ADMIN CONTROLLER

Ignore TinyMCE in Modules

SELECT MODULES

[0 Wishlist {blockwishlist)
[ Product Comments (productcomments)
[ Contact information {ps_contactinfo)

[ Newsletter subscription (ps_emailsubscription)
[0 Social media share buttons (ps_sharebuttons)

O Bank transfer (ps_wirepayment)

[0 Official GDPR compliance (psgdpr)

X Category tree links (ps_categorytree)

Clear all

Display mode Light made

O Contact form (contactform)

[ Banner (ps_banner)

[0 Cross-selling (ps_crossselling}

[0 Order Noifications on the Favicon
(ps_faviconnotificationbo)

Shopping cart {ps_shoppingcart)

0 Data mining for statistics (statsdata)

(O Prestashop Marketplace in your Back Office
(ps_mbo}

X Shopping cart (ps_shoppingcart)

() Dashboard Goals (dashgoals)
[ Category ree links (ps_categorytree)

[ Custom text block (ps_customtext)

[ Featured products (ps_featuredproducts)
[ Link List {ps_linklist)

[ Secial media fellow links (ps_socialfoliow)
O Stats Dashboard (statsforecast)

0 Prestashop Checkout (ps_checkout)

[ Ps Social with Facebook &amp; Instagram

Back l Translate ] [ Check update

[ Google sitemap (gsitemap)
[ Payments by check {ps_checkpayment)

[ Customer data privacy block (ps_dataprivacy)
[ Image slider (ps_imageslider)

[ Main menu (ps_mainmenu)

[ Theme Customization (ps_themecusto)

[0 Welcome (welcome)

[ Prestashop Metrics (ps_metrics)

[0 Marketing with Google (psxmarketingwithgoogle)

v

Manage hooks

Manage haoks



Click on “Save” button to finish.

IV. TINY MCE FORMATTING TOOLS

e Source code: this code editor makes it easier to modify the HTML, and it's a very

useful add-on for power users.

the blazing brillance of Tiftany
5 the baauty of mixechcut diamends.<p>
=315 =Tt e youtube. oo

-
You aiveady knaw how this Prastashop Instagram module

= froem your nstagram. Tag your products. Now anyene £an parchase ther.
L Orclers wil 3ppeas in Prestashop back office, JUSt ke you' expect </po-
your Pr »

¢ Font size: the TinyMCE rich text editor comes with 7 font size options by default,
ranging from 8pt to 36pt. Depending on how TinyMCE is configured, users can

select a font from the menu bar or toolbar.
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Love Ring in Rose Gold with Diamonds C

Standard product # | [3] en = T m

4.’ Combinations [2]

@® simple product

{/, [ © Product with combinations

Reference [
Summary escription w
File = Edi ~ View= Fomat~ Table v .
Quantity [
FontSizes ~  Font Family + - - g Paragraph +
328
st
o A0
1opt a~ win [
u: JERPAN
Tapt .
- Price [F]
181
Tax excluded Tax included
24pt
. s | 370.000000 s | 370
aept
Tax rul

US-AL Rate (4%)

Advancad settings In [ Pricing

i m online (J m Duplicate Go to catalog

e Font family: TinyMCE comes with 17 font options by default. Depending on the

editor configuration, users can select a font from the menu bar or the toolbar (via

the font select dropdown).

%% PrestaShop Quick Aceess = Q

Love Ring in Rose Gold with Diamonds o

Ty Combinations [I]

® simple product

Reference [
Summary |
Fiev SdLT Wsatv View Fomnarv Tabew Toals *
Quantity [7]
28
" 4 sestings i [/}

Price []

CONFIGURE

a

e Emoticons: lets users insert emoji into TinyMCE's editable area.
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73 PrestaShop 17: quickaccess « Q Seareh fe.p: product reference, custome @viewmyshop 1 P O

Love Ring in Rose Gold with Diamonds n Standard product ¢ | 7] en s
Basic settings Quantities Shipping  Pricing  SEO Options
', Combinations [
7N < ’ y 1 @ simple product
‘\;,,) éﬁ;}e ‘ '_ O Product with combinations.

Reference [7)

Summary Description -

Fiev €6t~ Insetv View Format~ Tablew Tools~
Quantity [

A > romszesv fontRmiyr © [] B I U T ow o= 6 E-=vi=-@E-® @ raagan- ()

e & 328

LR eEe®

OVe® A Advanced settings in [ Quantities

wh an ey SO® Tittany diamonds. The crgani: vina motif of thi ring complamants the basuty of

maxed-cut damands. PPE®
Price [
Tax excluded Tax included
$ | 370.000000 s 370
Tax rule

US-AL Rate (4%)

Advanced setings in [ Pricing

s B o @ B | ouetcace | [ Gotocatalog | | Add new product

e Anchor: lets users specify a custom name for the anchor in the URL type ahead

drop down.

¢ Text format tools: bold, italic, underline, strike through.
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Love Ring in Rose Gold with Diamonds

Basic settings Quantities Shipping Pricing SEO Options
2777
Summary Description

File Edit> insert> View v Format~v Table v Tools ¥

o -

Bold text

Italic text
Underline text
Sirike through text

With an intensity that rivals the night sk, Tiffany Victoria celebrates the biazing brilliance of Tiffany diamonds. The organic vine moti of this ring complements tha beauty of

mixed-cut diamonds|

<> fontszesv fontfamiy> © [] B r U T m o &

Block quote and link: format a paragraph into a block quote. Insert a link into the

paragraph.

Love Ring in Rose Gold with Diamonds

Quantities Shipping Pricing  SEO Options

W
. 9 ‘ﬁl

Basic settings

Summary

File v Editv Insert View~ Format~ Table ¥ Tools ¥

A <> FontSizes > FontFamily v

Standard product

v M @ raragraph~ ()

Standard product ¢

O parsgraph + ()
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Combinations 1

@ Simple product

O Product with combinations

Reference [7]

Quantity [

328

Advanted settings in [} Quantities

Price [
Tax excluded Tax included
$ 370000000 s 370

Tax rule
US-AL Rate (4%)

Advanced settings in [ Pricing

Combinations [

@ Simple product

© Product with combinations

Reference [I]

Quantity [

328

Advanced settings in (7} Quantities

Price 2
Tax excluded Tax included
s | 370.000000 5370

Tax rule
US-AL Rate (4%)

Advanced settings in (7} Pricing




Insert link

unt hetps:/iwwwtiffany.comt

Texttodisplay  Tiffany Victoria

Rel

Target

e Undo/redo tool.

¢ Align tools: align left, align right, align center, justify.

Quick Access v Q search (e g.: product reference, custome @ Viewmyshop 1 2 (2]
Love Ring in Rose Gold with Diamonds ® | sundadproduc ¢ (g ene % B = @

Basicsettings  Quantiies  Shipping  Pridng  SEO  Gptions

Combinations [Z]
@ simple product
@ éﬁ ] 7 O Product with combinations

|-

Reference [1]
Summary | Description -
File v Edit> Insert~ View~ Format~ Table v Tools ~
Quantity [
A < romsues~ Fontramiy> © [ B I U T w o & E-=vi=-E- A O regaph~ ()
= 328
s i — = Align Left
A|  Advanced settings in [ Quantities
With an intensity that rivals the night sky, Tiffany Victorla celebrates the blazing brillance of Tiffany dia = A0 Right “of this ring complements the beauty of
mixed-cut diamonds.
= Align Center
= Price []
Tax excluded Tax included
$ | 370000000 $ 370
Taxrule
US-AL Rate (4%)
Advanced settings in [} Pricing

8 Online (;, l Duplicate I l Go to catalog J l Add new product

o Bullet list: default, circle, disc, square list.
¢ Numbered list: default, lower Alpha, lower Greek, lower Roman, upper Alpha,
upper Roman.

e Table manager tool:

14



Quick Access v | Q@ search e.g.: product reference, custome |

@vewmyshop 0 WP O

Love Ring in Rose Gold with Diamonds » sandardproduc ¢ [ ens 2 B = @

Basicsettings ~ Quantitles  Shipping  Priing  SEO  Options

Combinations [2]

@ simple product
0
ﬁ O Product with combinations
Reference [1]
Summary Description £
File > Editv Insert> View~ Format~ Table v Tools ~
Quantity [
A < romszesv fomramy~ © [] B 7 U = - @~ | O regaphe () SR
- 328 |
LB | 8 Insert table B ——
A Advanced settings in [ Quantities
With an night sky, Tiftany Victoria of Tiffany ve mo A TWICRERTE e beauty of
‘mixed-cut diamonds.
A Delets table
Price [7]
»
Acet Tax excluded Tax included
Ak 5 370000000 || 5370 |
Tax rule
US-AL Rate (4%) -

Advanced settings in [} Pricing

Online (/)

n | Duplicate | | Go to catalog | | Add new product |

e Paragraph format tool:

Love Ring in Rose Gold with Diamonds |

Basic settings Quantities Shipping Pricing. SEO. Optlans

o ="

- standard product

M| A W =

s
5] bl | Translate Sales Product st Welp

Combinations [1]
@ simple product
O Product with combinations

Summary Description

File ¥ Edit> Insert> View~ Format~ Table ¥ Tools ¥

A <> Fotszesv Fothamiy> © [] B X U T w o 4 4 === G- W O pegoph~ ()

&> W — Paragrazh
Address

With an nsity vals Tiffany. iz 4 5.

‘mixed-cut diamonds. Pre

Quantity [7]
D

Advanced settings in [} Quantities

Header 1 Price [

Header 2 Tax excluded Tax included
Hesuscs ‘ s [ 370000000 s 370
4 = L3
i Taxrule
Header 5 x n |
‘ US-AL Rate (4%) ¥
[

l. [ZPricing

:

n I Duplicate l I Go to catalog | [Addnewvrudm:l

e Insert special character:
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Special character

oje|~

s -

firz

i

€
B
%)
v/
i
3
¥

o
"
ée
8
¥

e Print
e Preview
e Find and replace

e Add horizontal line

Find and replace

e Text color
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Clothes Standard product s 0 en s

m = @
Help

Sales Product list
Basicsewings ~ Combinations  Shipping  Priing  SEO  Options

Combinations ®

O Simple product

® Product with combinations

dvanced settngs n [} Combinations

Reference ®

Summary
demo_1
<> B I U & n g =~ = v vANM £vE = L OO
clothes someone wears tell us about their cultural identity and life statyl S to describe someone to Price ®
someone else, Tax excluded Tax included
5 | 100.000000 5| 100
| e i
US-FL Rate (6%) v

Advanced settings In (] Pricing

Categories ®

Search categories Q
137 of 800 choracters allowed
ASSOCIATED CATEGORIES

Description

Online (J E [ Go to catalog l [ Add new product

e Background color

Clothes Standard product s @ en s

Basicsemings ~ Combinatons  Shipping  Priding  SEO  Options

Combinations ®

© Simple product

@ Product with combinations

?l &

f r

y

Advanced settings n (7 Combinations

Reference @

Summary

demo_1

o B ] U S w L= EviEv@YEDB eragaph v A #vEEL DG
£

The clothes someone wears tell us about their cultural identity and life status. When ibe someone to Price ®
someone else, Tax excluded Taxincluded

$ | 100.000000 $ | 100

| e Texrue
US-£L Rate (6%) -

Acvanced settings n (7] Pricing

Categories ®

i Online (J E l Go to catalog l [ Add new product

e Decrease indent

e Increase indent

e Clear formatting: You can easily clear all formatting (such as bold, underline, italics,
color, superscript, subscript, and more) from your text and return your text to its
default formatting styles.

e Fullscreen
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e Insert/edit code sample

Insert/Edit Code Sample

Language
HTML/XML VJ

HTML/XML
JavaScript
Gss
PHP
Ruby
Python

Java
C
C#

Co+

-y

V. THANK YOU

Thank you again for purchasing our product and going through this documentation. We
hope this document is helpful and efficient in the installation and usage of the Advanced

Tiny MCE module. If you do have any questions for which the answer is not available in

this document, please feel free to contact us.
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